Newbie problem - finding Omen's Ring



  • First of all, hi! This is my first time posting here, and I've got to say, it's really neat seeing an active community for such a random old game!

    So, my question is probably one that will be answered in the first reply and I'll be all like "Ohhh... :mellow: duh.", but it's frustrating me, so I'm going to ask anyway.

    To get Omen's Ring (according to Slayer's guide, which I usually understand), you're supposed to go through a secret door in the starting room of the test and then through a second secret door from there and end up in a room with a torch that you search, and everything's happy, yay.

    The problem I'm having is: I can't find the second secret room! Geez! I'm assuming that the first secret door is the one that opens up in the starting room when you throw the switch. I've searched the walls in there, tried to walk through them, lit a torch and looked around, and... well... I started a new game, so that's really all I can do. I don't see anything else. And that's the same with the little secret room with the ladder through the secret door behind the torch. Do I have to complete other parts of Omen's test to unlock the second door? Or am I missing something obvious? Any help would be appreciated - thanks!



  • Welcome to Cythera! How exciting :D

    Spoiler

    You search for the second secret room from the first secret room ^_^



  • Oh, haha, I guess I was a little vague. I already searched there. (And down the ladder in there, and I tried past the curtain, but obviously I was then teleported out.) I just can't find anything.



  • I'm not confident about this, but I believe

    Spoiler

    the second room is to the left of the first room, and you just "walk" through the wall; you don't search for it.



  • Thanks, but sorry, I've tried that as well, but my character just stands there. In the meantime, I've tried a few different things - solving the dynamite puzzle to see if it unlocks, solving the lever-under-crates puzzle, I've even gone to the teleporting maze and flipped the switch at the center and gone back and still nothing. Your idea seems to fit with what Slayer's guide says, though. It's possible my game is bugged.



  • Spoiler

    Try the opposite wall in the secret antechamber containing the crate with the key in it.



  • vIsitor - thank you, thank you! That is totally not the secret room I thought I was supposed to be searching in! I found the ring, and life will go on. :p



  • No problem. I remember when I was a newbie, way back when, I didn't even know what omen's ring was , and so was thoroughly confused whenever it was brought up in conversation (not to mention Omen's cryptic message about not finding the treasure in the 'test').



  • I didn't know what Omen's ring was ethier, oh and Lioness Backfire don't feel bad that you didn't get the ring. The first time I played Cythera I got to the bomb puzzle lit the bomb. Didn't know what to do next so POW :ninja: sent back to the triangle.

    Hello Lioness Backfire

    This post has been edited by IT 000 : 20 September 2007 - 05:33 PM



  • Greetings, Lioness Blackfire, and welcome to the Cythera Web Board :) .

    Indeed, I too was unable to find the Test reward when I first played.



  • @lioness-blackfire_bot, on Sep 16 2007, 10:28 PM, said in Newbie problem - finding Omen's Ring:

    First of all, hi! This is my first time posting here, and I've got to say, it's really neat seeing an active community for such a random old game!

    Oh my! Another new member! Hello and welcome, Lioness Blackfire!



  • Welcome to the boards! Make yourself at home!

    I'm glad to see that ~visitor~ was able to answer your question, that seems to be a commonly misunderstood passage of Slayers Guide, (at least if you + me = normal?)



  • good lord! they pop up like daisies!
    Welcome, Lioness Blackfire!



  • When I first played I had no idea what basic RPG rules are and I didn't know how to "drop" a bomb som I kept blowing myself up. However, even after I got past it it wasn't until a year (literally, not Cythera time) later that I found the test in Cademia and there found the ring.


Log in to reply