To boldy go where no Cytheran has gone before. . .



  • Title based upon a topic by Bryce

    Back in late 2001, Bryce posted a topic entitled "To boldy go. . ." This topic could well be called "Part II."

    Here are a couple excerpts from that topic that I found interesting:

    Quote

    Honorable members of the board, Moderators, distingushed guests,
    I propose a grand mission of exploration. To travel to every corner of Cythera, every hidden place. To unlock the secrets of the ages, and to BOLDLY GO WERE NO CYTHERIANS HAVE GONE BEFORE!


    I think the hack is the only way to get into the Landking hall area. I walked around there quite a ways, as you can see on the map, and found a whole 'backstage' area. There was a dead guy, some carpet, and other, useless stuff. The only interesting thing I found was the Blue Crystal Globe, Which, by the way, behaves just like the regular Blue Crystal Globe. I'm inclined to belive that the 'Secret room' is more error than easter egg. The dresser was empty, as well

    Soon after, Bryce posted "Taking requests for exploration." This topic also has some interesting posts relating to the teleporting hack.

    Quote

    Exploration of the Abydos ruins:
    I teleported thorugh a wall under Abydos and found myself in an area not unlike the LKH White Room. As well as having the same white floor (Which I speculate is the default when no other tiles are placed there) Scattered and partly complete walls were common. Sadly, I found no items or things of interest. However, I wouldn't say the trip was a failure, as the similarity to the White Room adds weight to my theroy that the White Room was not intended as an easter egg.


    Results of Lava-Pool exploration in Land's End Valcano:
    Inital results were promising, I thought I saw a passage on the other side of the pool. However, on further examination, I turned out that this was not the case. I did find some obsidian, however.

    I'm also going to quote a post from Bryce in an old topic called "Braziers....?." This is reply #8:

    Quote

    Anyway, the result at the end of the day is that all the inaccessible' places we knew of got visited, along with some that were discovered with the teleport hack. The kitchen in the stronghold (Slayer was there first), thewhite room' (Visited by me), some `black areas' in Cademia, parts of the coastal temple with the hydra things, and so on.

    Which isn't to say they aren't worth visiting yourself, of course - although the white room is the only one I know of that provides something more than strange sights. (You can pick up and take a blue orb, as I said previously. The kitchen might have stuff as well, I never visited it after Slayer didn't find anything good there. Ask him.)

    That ends the introduction. So, why am I posting so many links to all these old topics? Because the question of what may be in the unexplored areas of Cythera, particularly the white room, has been tossed around for a while now. I find it a little amusing that the answer to all of our questions has been here all along, right under our noses.

    However, as Bryce says, the fact that it's been done before is no reason to for us not to try it. So yesterday, Selax and I booted up Sheepshaver, loaded Bryce's tutorial on Slayer's Guide, downloaded ResCompare and HexEdit (Bryce's links are broken, but you can do a google search to find a working download), and got to work.

    At first it was very difficult. You have to find which addresses the char's location is saved at, which change each save, and know what to change them to. It took a little while, but I'm pleased to say that we were eventually met with success! Screenshots are included below for your viewing pleasure. . .

    Before I go too much farther, I would like to mention that if you decide to do this, Bryce's guide can be confusing at points. Post any questions you have here. If I work up the energy:laugh: I may even take the time to write my own version of his guide; I doubt it will be necessary, though.

    Our first destination was the "White Room" in LKH.
    http://i180.photobucket.com/albums/x230/El...heWhiteRoom.jpg
    As you can see, there is a scrap of carpet, a dead ruffian, and three tight passages. . . nothing happens when you use the passages.
    http://i180.photobucket.com/albums/x230/El...ngtoacorpse.jpg
    Interestingly enough, you can speak with this particular corpse.
    http://i180.photobucket.com/albums/x230/El...lkingcorpse.jpg
    Finally managed to find someone who's not hungry under "Status!" There is more white off to the right, scattered fragments of cave wall along portions of it, but nothing of interest in that direction.
    http://i180.photobucket.com/albums/x230/El...gtheDresser.jpg
    To the left and up, one finds the mysterious crystal ball and dresser. The crystal ball is normal. . .
    http://i180.photobucket.com/albums/x230/El...a/ItisEmpty.jpg
    and the dresser is, sadly, empty.

    Land King Hall was not the only place we tried. Here's a pic of what it's like outside the teleporting maze in Omen's Test:
    http://i180.photobucket.com/albums/x230/El...ndOmensTest.jpg

    This is what you get if you translocate into the empty space behind the inn in Cademia.
    http://i180.photobucket.com/albums/x230/El.../IntheAbyss.jpg
    You can't move, see, or do anything. It's just a black pit.

    I want to apologize if all these images are clogging your bandwidth, I didn't want to have to crop them all. I wasn't even sure where I would crop them since one includes a dialogue box. So I invite you to check the full album at: http://s180.photobuc.../Elyus/Cythera/

    By way of commenting on my own post, I would like to add that the question about unexplored areas is just one of many other mysteries about Cythera. I remember that I once posted a question about spells that weren't in the final game but were pictured under the documentation, and there has been an infinite number of questions about fishing. Though it's clear to me now that all of these mysteries were things that simply never made into the final release of the game for one reason or another. But there are more interesting ones that I've been discovering just recently.

    In the midst of editing the data of saved game files, I was very intrigued by the fact that part of the data that could be read was right at the top of the file, always saying" Cythera Fate of Alaric." Perhaps this was the working title at an early stage of development? I can't find anything now pointing to "Fate of Alaric" as part of the official title. Pity, I think it's rather catchy. . . :p

    Additionally, part of the readable data contains a list of all the maps (or zones) that are in the game. They are all accounted for, except one:
    Posted Image
    The Tree of Life. This is particularly eye-catching. A whole map that has never been visited? I keep thinking: if we've mastered in-city teleportation, is it possible to master inter-city teleportation? If so, can we reach this place called Tree of Life or was it just another part of the game that gandreas named but never did anything with? Just a thought to leave you with.

    Comments are very welcome.

    Edit: Now that the novelty of this topic has worn off, I have edited this post to have only links to the larger images. I was getting tired of waiting on it to load just to read some post on the first page :p (Secretly, I also didn't like the way the images stretched my profile page.)

    This post has been edited by The Wizard : 27 September 2007 - 12:53 AM



  • Moar



  • . . . Well. . . does anybody else have a comment?



  • What else but, HOLY CRAP!

    I looked through Cythera recently and also was puzzled by that tree of life thing. I'm glad to finally see screenshots of the blank space in LNK and co. thanks. If only the map names were in some type of order, that might have given us a clue.

    I rember useing a crytsal ball once to look past the ocean, and I beleave I saw white space. That might be interesting to look into.

    Thanks for all this valuble info. :)

    EDIT: WOOHOOO!!! POST NUMBER 300!!! :D

    This post has been edited by Two Jacks : 05 August 2007 - 06:35 PM



  • I would really doubt inter-regional teleportation could be done in a manner remotely similar to this. When you enter a region, all of the data for the map, tiles, characters, and everything else have to be loaded into memory. None of that would be correctly loaded if you simply changed the "region" value in memory.

    One thing that's conceivable is that there should be a "enterRegion(x)" function in memory. If you could find that function, decode its signature, and call it, then you could probably cause the game to trap to the Tree of Life region. But that would be very difficult, and I don't know if the tools would support it.



  • I find it unlikely that the Tree of Life is included in the game (at least as a playable zone and one that can be reached through ordinary means), since no one has ever yet found it. As an interesting aside, the message that the braziers give out is, according to Slayer, a reference to the Order of the Tree of Life, which one of the other old posts revealed is a reference to a branch of Jewish Mysticism (the Caballa I think although doubtless I have misspelled it). Wizard looked it up and discovered it could be a reference to something Greek, as there is a Greek Kaballa.

    Regarding teleportation, I have found vertical teleportation to be the easiest, as I don't quite completely yet understand horizontal. By the way, if you have the map closed off to the side, you will only have to change two values to teleport your character. (Personally, I also close the inventory.)

    I'm inclined to agree with Pallas regarding inter-regional teleportation. I have found that moving between two cities results in a massive number of differences between two saved games.

    This post has been edited by Selax : 06 August 2007 - 02:29 PM



  • Its almost impossible to know if the "Tree of Life" region actually contains anything, because the actual data is encrypted almost in its entirety. There are some parts I am sure is dialogue, and others that I suspect define regions, but I can not actually make sense of it without a primer. However, I think the Tree is defined as a area, at least in terms of relative dimensions, if not the tiles.

    Anyway, attempting to enter the unseen area is a worthy goal indeed. Even if futile, it is surely worth the attempt. Now, isolate the code for position and time so they do not interfere, and attempt to determine the code for regional location. If more than a little changes, then then it is likely that the region is being loaded into memory. However, if we cross reference the changes in the player file with the core data, then it might be possible to determine which partition of data defines which region, even if we can not decipher the content. Through process of elimination, we could determine which is the "Tree of Life", and forcibly upload it into the player file.



  • OMG. :blink:

    Well, for starters, where do you get that broken-link program (not HexEdit, I already have that)?

    How about exploring those weird permanantly-locked doors in the first stronghold?

    What could the "Tree of Life" be anyway?

    (On a side note, "Tavara Fortress" pretty much confirms that lich is Tavara)

    This post has been edited by Buzzzzy : 06 August 2007 - 03:31 PM



  • @-visitor-_bot, on Aug 6 2007, 12:35 PM, said in To boldy go where no Cytheran has gone before. . .:

    Its almost impossible to know if the "Tree of Life" region actually contains anything, because the actual data is encrypted almost in its entirety. There are some parts I am sure is dialogue, and others that I suspect define regions, but I can not actually make sense of it without a primer. However, I think the Tree is defined as a area, at least in terms of relative dimensions, if not the tiles.

    Anyway, attempting to enter the unseen area is a worthy goal indeed. Even if futile, it is surely worth the attempt. Now, isolate the code for position and time so they do not interfere, and attempt to determine the code for regional location. If more than a little changes, then then it is likely that the region is being loaded into memory. However, if we cross reference the changes in the player file with the core data, then it might be possible to determine which partition of data defines which region, even if we can not decipher the content. Through process of elimination, we could determine which is the "Tree of Life", and forcibly upload it into the player file.

    Elementary my dear watson! :p



  • How's this for a theory: The Tree of Life is that weird broken map with a guard that a few Cytherans have been teleported to (through dead bodies) in the past? giggles



  • @breadworldmercy453_bot, on Aug 6 2007, 02:31 PM, said in To boldy go where no Cytheran has gone before. . .:

    How's this for a theory: The Tree of Life is that weird broken map with a guard that a few Cytherans have been teleported to (through dead bodies) in the past? giggles

    I concur, except for the giggles part. It is an incomplete map so that meens it could be the Tree of Life, but it alsomeens it could also be any unfinished map.



  • They're called things like "Map" and "New Map" and appear different each time. I doubt these have anything to do with the Tree of Life. My theory is that they are either templates or randomly-generated glitch maps that are created as a result of a screwed up ID of what a corpse is (which is again a glitch unless Glenn intended it as an easter egg).

    This post has been edited by Buzzzzy : 06 August 2007 - 09:33 PM



  • Out of curiosity, ~vIsitor~, what tools do you use to look at the Cythera data? (At the moment, I'm using ResEdit, ResCompare, and Hex Edit.)



  • All I've got is an unregistered early version of Resourcerer. Good for looking at the raw data and the resource divisions, but since its unregistered I can't actually change anything (or compare any of it, for that matter). Since the datafork itself ( <df>) if encrypted, I have a hard time understanding any of it (its kind of like the Matrix). However, at times there are blocks of indecipherable text that I can only assume are dialogue, and extensive repetitions that I would presume define locations within the game.

    I'm fairly certain that the Cythera program itself holds the rules that the game follows, as well as the key to cracking Andreas' cleaver Delver encryptions, but really little else. The real data is in the library file (Cythera Data), and the save files. Of course, trying to decipher the meaning of any of it is like trying to understand a foriegn language by looking at the pictures in a dictionary.

    I also use Cheat II, to a lesser extent, but its not so good at changing things wholesale.



  • If you click at the link above "Braziers....?." and look around on the post, it says something about that you can get teleported to this room with a door that opens to void. Perhaps that is the Tree of Life?

    EDIT I found the quote EDIT

    Quote

    What I have found, however, is that by taking a secret earthen passageway, you can find a hallway which takes you to a room that contains braziers, two pools, and a door which opens on the void. Does anyone know what this room is?

    Quote

    As you can see, there is a scrap of carpet, a dead ruffian, and three tight passages. . . nothing happens when you use the passages.

    I remember posting about this!
    --------
    I am also a proud surviver of the map with random tiles, I posted something on it way back when.

    This post has been edited by IT 000 : 19 August 2007 - 12:20 PM



  • Nice to see that tutorial is useful to someone years later. I apologize for my younger self's poor technical writing. It's still not my strong suite.

    Regarding teleporting to other zones: Pallas is correct in saying that changing it directly it is not likely to be usefully possible for the reasons he names. However, It is possible to change the area that a portal-type object (like a hole, outside view of a town, stairs or whatever) points to. I thought I had made a post concerning that at one point but I may be mistaken. Obviously the trick here is getting a hole to hack. Put a some coins from your inventory (not all of them) on the ground. Save the game. Take a small number of the coins and put them back in your inventory, noting the number of coins on the ground before and after. Save as. You can then run a diff on the two saves to identify where the parameter associated with the number of coins for that particular coin pile is located in the save file. (This is a way to enrich yourself as well, should you desire to abuse the awesome power of save-file hacking in such a mundane way.) Then, change the coins into a hole, and alter the parameter to point to the desired area. This step is left as an exercise to the reader: I've done it before, but I don't remember the particulars (which of the bytes preceding the one you identify as having changed is the item type, which item type is a "hole", what the valid zone parameters are, and so forth), but they can be worked out by trial and error in your copious free time. You will see many interesting things.

    Edit: you get off easy after all. On a hunch I looked through my old files connected with the abortive Cythera X work. This list may be useful to you. Or it may not. I can assure you that the one thing it will do is confirm what I said about my lack of technical writing skill. :D It does have many interesting magic constants though, once you've figured out how to get to the right data in the save file. The file doesn't really say other than that the objects are in a 16-byte record and that "byte seven" (probably the eighth byte, the numbering starting at zero in the ancient custom of programmers) is the one that will change when you change the number of oboloi. (So if you can count backwards I guess you're set.)

    hex
    10	oboloi in inventory
    01 	not in inventory?
    ff	nothing/unused
    
    16 byte record
    byte 3 - Y position, apparently. leads one to suspect that
    	bytes 0-2 might be zone or position related.
    byte 0 - ff - nothing.
    byte 4:5 - object type
    	05 41   Green crystal orb
    	05 42   lit bomb.
    		byte 6 - fuse length. (01 = nasty suprise...)
    	05 44   Mounted gator head.
    	05 45   Sword dummy
    	05 46   Broken sword
    	05 47   Dice (behaved like a scale)
    	17 82 - shrub.
    	18 9A	A pitcher that behaves like a lyre.
    	18 89 - 6 oboloi pile
    	18 88 - 4 oboloi, but they don't stack with normal ones
    	18 87 - a skirt, but it behaves like an inkwell
    	18 86 - strange device
    		(but gives a message: "It is blank." when you use it.)
    	18 85 - sulfur
    		(does not exhibit butter phenomina of seed pods.)
    	18 84 - seed pod 
    		NOTE - this object apparently contains a pointer to a script
    		or something as I ended up with a seed pod that could be used
    		to butter bread. unfortunatly it is not clear where the pointer
    		is. (tested poking 10 into each of the 00 bytes and no change.)
    
    		It would seem that objects with scripts have some additional 
    		game state somewhere and turning oboloi into an object that
    		should rightfully have scripts causes random collosions.
    		(Note - it seems possible that the structure for these
    		extended objects is 32 bytes but preliminary experiments
    		may contradict this: turned crystal ball into dice. It behaved
    		like a scale, not a crystal ball.
    	18 83 - stairs (non-functional)
    	18 82 - oboloi
    	18 81 - vat
    	18 01 - encampment (4 buildings make a town)
    	18 02 - stairs down
    	18 03 - top of a door.
    	18 04 - archway
    	24 51 - female mage
    	24 50 - male mage
    byte 14: involves position.
    
    In the case of stacking objects, byte 7 is the quantity.
    
    In the case of certain objects (such as the seed pod, 0x1884) the use of
    byte 7 is unclear. 
    
    In the case of portal objects (e.g. stairs or towns), byte 7 determines
    where you go. some Valid places:
    	01: LKH Summoning triangle (logical!)
    	02: Outside LKH
    	03: inside LKH
    	04: inside Odemia
    	05: outside Odemia
    	06: outside abandoned farmhouse ( kidnapper's hideout)
    	07: inside abandoned farmouse
    	08: cellar of abandoned farmhouse
    	09: next to ladder going into cellar (see the pattern here?)
    	0a: outside catamarcia
    	0b: inside catamarcia?
    	0c: next to ladder going into catamarcia underground spring
    	0e: next to ladder going into catamarcia underground store-cave
    	10: to a point in the south of catamarcia, next to the ocean.
    		just north of this there is actually a secret passage that
    		also goes into the catamarcia underground spring.
    	12: outside cademia
    	14: next to the cave hole in LKH north store-cave.
    	16: outside UrSlyph's prison
    	18: in the east of the cave that leads to Maayti.
    	1A: ditto, but the west entrance
    	1C: timon's seldane ruins
    	1D: Outside swamp ruins
    	1E: Inside swamp ruins
    	1F: outside Pnyx.
    	20: inside pnyx
    	22: inside Kosha
    	26: beside east stairs on Pnyx bottom floor.
    	28: beside east stairs on Pnyx top floor
    	2f: 'nowhere' underneith pnyx.
    	40: deep inside land's end volcano
    	50: outside Borus's vineyard
    	60: inside mining camp
    	70: in cademia, next to the ladder going to the golem door puzzle thing
    	80: deep inside harpy cave
    	90: Cademia side of the bridge where Demodocus often hangs out
    	a0: by rock outcropping of harpy cave chasm
    	b0: Under Pnyx (the room with the fountain)
    	c0: nothing
    	d0: nothing
    	
    000008ED: 0B (11) -> 0F (15)
    000008F4: D7 (215) -> ED (237)
    000039F2: FF (255) -> 10 (16)
    000039F4: 03 (3) -> 00 (0)
    000039F5: 41 (65) -> 01 (1)
    000039F6: 4C (76) -> 18 (24)
    000039F7: CC (204) -> 82 (130)
    000039F8: 31 (49) -> 00 (0)
    000039F9: 00 (0) -> 1B (27)
    00003AF2: 10 (16) -> 20 (32)
    00003AF3: 00 (0) -> 0C (12)
    00003AF4: 00 (0) -> 60 (96)
    00003AF5: 01 (1) -> 3A (58)
    00003AF6: 1C (28) -> 18 (24)
    00003AF9: 3A (58) -> 1F (31)
    
    01
    cb:
    000008ED: 0B (11) -> 1E (30)
    000008F4: D7 (215) -> F9 (249)
    00003FD2: 10 (16) -> 20 (32)
    00003FD3: 00 (0) -> 0C (12)
    00003FD4: 00 (0) -> 60 (96)
    00003FD5: 01 (1) -> 39 (57)
    
    
    clearing unexplored on mainland
    0003C1F8: 1F (31) -> 9F (159)
    0003C218: 1F (31) -> 9F (159)
    0003C238: 1F (31) -> 9F (159)
    0003C258: 1F (31) -> 9F (159)
    0003C278: 1F (31) -> 9F (159)
    0003C298: 1F (31) -> 9F (159)
    0003C2B8: 1F (31) -> 9F (159)
    0003C2D8: 1F (31) -> 9F (159)
    0003C2F8: 1F (31) -> 9F (159)
    0003C318: 1F (31) -> 9F (159)
    0003C338: 1F (31) -> 9F (159)
    0003C358: 1F (31) -> 9F (159)
    0003C378: 1F (31) -> 9F (159)
    The cytherian mainland is apparently 8*64 = 512 tiles across
    
    
    
    appear to be 16-byte object records around 48e60, but starting at B
    rather than 2. Also there are (similarly alligned) object records around
    48e8e. although these records clearly involve characters,
    changing the object type here  isn't persistant. So clearly something else
    (possibly an associated script) is controlling it. The pointers to these
    scripts must be elsewhere... they are not apparently in the object record.
    
    prusa moving:
    00044B3E: 77 (119) -> 78 (120)
    00044B3F: 20 (32) -> 24 (36)
    00044B4D: 01 (1) -> 02 (2)
    00044B53: 17 (23) -> 16 (22)
    
    00048E8E: 77 (119) -> 78 (120)
    00048E8F: 20 (32) -> 24 (36)
    00048E91: 30 (48) -> 20 (32)
    04
    
    meleager joins
    000008ED: 0A (10) -> 0B (11)
    000008F4: BF (191) -> DC (220)
    0000092E: 03 (3) -> 00 (0)
    000445DD: 04 (4) -> 00 (0)
    000445E1: 83 (131) -> C3 (195)
    000445EB: 00 (0) -> 02 (2)
    000445EF: 8F (143) -> 01 (1)
    000445F1: 06 (6) -> 07 (7)
    00048BBD: 04 (4) -> 00 (0)
    00048BBF: 20 (32) -> 10 (16)
    
    variables related to the hero/ine are located around 92e
    

    Fun thing you might want to do: Put some stacks of coins in the room in LKH where directed nexus takes you. Turn them into towns pointing to the various cities in Cythera. Congratulate yourself on putting save-file hacking to the constructive use of making a handy teleportation network. I haven't done this, but it should work. I don't know if it would persist though, I never bothered to figure out the rules for objects persisting. It sounds really freaky, but you might even be able to change oboloi in a container into a portal object pointing to the right area, add some more oboloi, and repeat, thus making for yourself a portable teleporter in a box, sack, corpse (in the case of some of you, who are freaks), or whatever. Again, I haven't tried changing the type of an object that is contained in another object, but I don't see why it would be impossible and it would be handy for exploration.

    This post has been edited by Bryce : 19 August 2007 - 05:16 PM



  • Wow Bryce, you rule!

    I'm not great with programming as I'm sure I'm not the only person. So the only way I think alot of us can enjoy this kind of stuff is if some one uploads a Save file onto the add-ons page that is in these situations.

    So many interesting things.. It's awsome! :)



  • Oh my, it's Bryce!

    It's good indeed to see you again, friend. Admittedly, most of what you said went over my head, but from what I understand you have determined the means of changing the identity of objects in Cythera; this is a great leap forward indeed. If you can identify the precise nature of each object's code, a secret you clearly have begun to ply, then it would be a fairly simple matter to insert new objects into the game itself.

    You have lived up to your reputation well indeed. With your expertise there is hope for Cythera yet.



  • Uh, thanks. It's just elementary though, nothing fancy.

    I don't have time to make up a full tutorial, nor to make up saved games demonstrating this crazy stuff, but since there seems to be some interest in further exploration of this technique (and because I'm kinda curious about this whole Tree of Life business myself), I'll try to explain the list a little more.

    In a C++ program like Cythera, there is a kind of data structure called a "struct", which is also called a record. A struct is a way of grouping related data together, and it apart from making programs much easier to write and understand, it's also the foundation for objects in C++. When you write a struct to a file, though, it just gets collapsed into a string of numbers, just like any other data. You can imagine it this way: Say you have a piece of paper and cut some holes in it. Next to the holes, you write some labels, like "X position," "Y position", "Percent Similarity to a Gnome", or whatever. Then you place another sheet of paper under this template, and write numbers in the holes. Cythera save files are a set of papers with numbers on them. We don't have the templates (the pages with the holes and labels), which represents the struct definitions of Cythera. So, developing new kinds of save-file editing is basically attempting to figure out the template and the labels from comparing sets of numbers (save files) with known differences (position, number of oboloi, etc.) There are a few complications, but that's the essence of it.

    One of the papers-with-holes (structs) is for the objects in the game. The set of numbers that goes with each one is 16 bytes long. (A byte can be thought of as a number from 0-255 inclusive.) The file I posted in the code box is basically my notes attempting to describe the struct that goes with these sets of data, of which a cythera save file contains many. (There are, after all, many objects in Cythera!) For instance, the fifth and sixth bytes of one of these records change the object type. (Although it must be more complicated on some level because the full behavior of the desired object is not usually replicated, or leads to oddities like seed pods that butter bread.) So, with that file acting as your template, you're good to go, right?

    Well, there is one complication; you have to find the place where the object record you want starts - basically, there is no direct way to tell where one struct's set of numbers ends and another begins: imagine that a cythera save file is great scroll (or maybe some old fanfold computer paper) with a list of numbers on it, written using pages-with-holes you don't have, a hundred kilometers long. Where to you place your newly divined template on that continuous stream of numbers? This is where you simply apply the same technique you use for finding the address in the save file of your character's physical position on the map. (Although I suggest you use the quantity-parameter and some stackable objects like coins, rather than the position.) When you find the position of the quantity parameter by changing the quantity and comparing two saved games, you know you can "line up your template" there and count backwards three bytes and be at the first byte of the Object Type field.

    I hope that clears things up a bit. And yes, you can have lots of fun doing stuff like this, but with college and all I have just enough have time to work on one or two side projects, and really save-file hacking, however clever, isn't going to fix Cythera's OS X problems or enable anyone to create new Delver scenarios.

    Edit: with regard to new items:
    While I don't see any reason why you couldn't conceivably create items ex nihilo rather than changing other items (providing you can find the table of objects in the Cythera data file, it's actually easier than I implied to see where each object record begins since the empty ones all begin with 0xFF and you could just fill in an empty one with correct data), I don't think it's possible to create new types of objects. You can make novel variations on objects (like a "magic ladder" that teleports you to LKH, which is unlike any other object and hence a "new object" from the player's perspective), but the object is still essentially a ladder (an object which moves you from one area to another), only the parameter (the destination) has changed.
    You might also be able to combine objects of one basic type with the scripts associated with another (My Seedpods of Buttering probably fall into this category, but I didn't explore it much). Neither of those things, though, really constitutes making a "new object" in the sense of something truly novel in Cythera. I think that you'd need to be able to edit the Cythera scenario/data file, which is unhappily opaque to us at the present time.

    This post has been edited by Bryce : 20 August 2007 - 12:15 PM



  • Great to see you around, Bryce. Thank you for posting that list and your other information on zone teleporting.

    Using the information supplied by Bryce and after some work, I was able to first change the type of item in my inventory and then, after some more work, to change the oboloi on the ground into a set of stairs that led outside LKH. Unfortunately, these stairs disappeared; thus, I decided to create them in my inventory and see what happened. This venture was a success: the character teleported and the stairs remained in my inventory.

    I have created one character with two flights of stairs (one of which seems stuck on leading to Odemia) and the other of which I am using to investigate zone numbers. This is actually quite easy, as only byte must be changed and it is located at a static address. (Inventory items seem to be mostly located in the 00003E(insert some letter here)0 range.) In theory, I could upload this file and try to explain more about its use. Then, we could assign zone numbers to check and have an organized effort to attempt to discover where all such numbers lead. Using this character, I have reached a chamber under the sewers in Cademia and what might be the infamous "Nothing" map.

    I have also created a character (a mage) with five flights of stairs. Each one of these leads to a city (all except LKH) enabling rapid travel. I could upload this as well for those who are interested.

    Here is a list of the zone numbers that I have explored (note: it is not as precise or neat as Bryce's):

    0f: in catamarca underground
    13: Cademia entrance
    15: Odemia entrance?
    17: tight passage exit on path
    19: just in front of tight passage
    1B: in front of Timon ruins
    21: outside Kosha
    23: outside Pnyx stairwell
    24: outside Pnyx stairs
    25: outside Pnyx stairs
    27: outside Pnyx stairs
    29: outside Pnyx stairs
    2a: outside Pnyx stairs
    2b: Under Pnyx (Diones office)
    2c: Pnyx library
    2d: Under Pnyx (In wall?)
    2e: Under Pnyx
    30: Seldane city
    31: Outside Seldane entrance
    32: Iron mine entrance
    33: Entrance to above mine
    34: Iron mine (ladder dead end)
    35: Iron mine (outside ladder)
    36: Iron mine (ladder to upper left of entrance)
    37: Iron mine (exit from above ladder)
    38: Iron mine (exit from ladder to hole)
    39: Iron mine (entrance to ladder to hole)
    3A: Iron mine (ladder to dead end on right)
    3B: Iron mine (ladder dead end)
    3C: Iron mine (next to hole)
    3D: Iron mine (jhiaxus)
    3E: In front of LKH volcano entrance
    3F: LKH Volcano entrance
    41: LKH Volcano
    42: LKH Volcano
    43: LKH Volcano
    44: LKH Volcano
    45: LKH Volcano (dead end)
    46: LKH Volcano
    47: LKH Volcano
    48: LKH Volcano
    49: LKH Volcano (jinrai's chamber?)
    4A: Outside Charax's house
    4B: In Charax's house
    4C: Outside Northern vineyard
    4D: In Vineyard
    4E: entrance to hall of truth
    4F: Maayti entrance
    55: ratcatcher's home
    5A: Sewers (next to bridge)
    5C: Outside farm
    5F: Kosha grotto
    65: scylla temple
    6A: Outside Cove
    6C: Outside hole to north of Cove entrance
    6F: Machaon workshop
    75: below abydos
    7A: Ruffian Encampment
    7C: First Stronghold stairs to down
    7F: Harpy cave
    85: Cavern system (Eioneus)
    8A: Caves (Eioneus?)
    8C: Caves (next to rope down)
    8F: Entrance to bridge
    95: Omen's test
    99: Omen's test
    9A: Omen's Test
    9C: Omen's Test
    9F: Mountains
    A0: Mountains?
    A5: Crypts
    AA: Crypts
    AC: Crypts
    AF: Crypts
    B0: Crypts (diones office)
    B1: LKH (Seldane teleport point)
    B2: Stone (Seldane east point)
    B3: Swamp Ruins (south point)
    B4: Timon Ruins (west point)
    B5: Underground sewer chamber
    B6: Entrance to chamber
    B7: End of Omen's test
    B8: Entrance to end of test
    B9: Cademia (outside trapdoor to Omen)
    BA: Omen's Test
    BB: Cove
    BC: Cove
    BD: Ur-sylph's prison
    BE: outside Ur-sylph's prison
    BF-FE: Nothing map (not all checked but can be assumed)
    

    Either I or Wizard will attempt to upload a few screenshots later.

    To me, the zone numbers 2c and 2d are quite interesting. Most of the others seem to be located at zone entry or exit points, but 2c puts me in the library and 2d puts me in a wall under Pnyx, in a version of the crypts without teleports and with Pnyx sound and such.

    This post has been edited by Selax : 20 August 2007 - 05:28 PM


Log in to reply